Degraded performance in Alumio systems due to AWS outage

Incident Report for Alumio

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 09:57 CEST

Update

AWS has reported that the issue in the US-EAST-1 region has been mitigated, and services are showing strong signs of recovery. Alumio systems are stable, and all core services are operational. We will continue to monitor for any residual impact and provide updates if conditions change.
Posted Oct 20, 2025 - 13:22 CEST

Update

Our monitoring concluded that the incident no longer impacts our systems. However AWS has not closed the incident yet and we will continue to monitor the situation.
Posted Oct 20, 2025 - 13:04 CEST

Update

We continue to observe recovery across most of the affected services. Global services and features that rely on the US-EAST-1 (N. Virginia) region have also recovered.

Our website www.alumio.com, AS2 services, and related services are showing stable performance. NON-EU servers may still experience slightly increased response times as AWS completes its recovery process.
Posted Oct 20, 2025 - 12:13 CEST

Monitoring

Alumio is currently experiencing partial service degradation due to an ongoing AWS outage in the US-EAST-1 (N. Virginia) region. This issue is causing some elements on our main website www.alumio.com and on our AS2 services.

AWS engineers have applied mitigations and are reporting early signs of recovery. Most requests should now be succeeding, but some latency and delayed processing may still occur while AWS clears its backlog.
Posted Oct 20, 2025 - 11:51 CEST
This incident affected: Alumio Website, AS2 & EDI Services and Alumio Cloud Network (Alumio Cloud Network [EU], Alumio Cloud Network [NON-EU]).